Skip to content

show_topology fails when TREMA_TMP is other than TREMA_HOME/tmp #24

Description

@amotoki

こんな感じで Trema を起動しているのですが、

sudo LOGGING_LEVEL=$TREMA_LOG_LEVEL TREMA_TMP=$TREMA_TMP_DIR
trema run -d -c $TREMA_SS_CONFIG

Trema は gem でインストール、TREMA_TMP_DIR は /opt/stack/data/trema になっています。

そうすると、

ubuntu@ostack01:/opt/stack/trema/apps/topology (current)$ sudo ./show_topology -g
Failed to bind ( fd = 4, sun_path = /tmp/sock/trema.show_topology.m.sock, errno = No such file or directory [2] ).
Failed to create a receive queue.
Failed to bind ( fd = 4, sun_path = /tmp/sock/trema.topology-client-28184.sock, errn o = No such file or directory [2] ).
Failed to create a receive queue.
Failed to bind ( fd = 4, sun_path = /tmp/sock/trema.topology-client-28184.sock, errn o = No such file or directory [2] ).
Failed to create a receive queue.
Could not create a PID file: /tmp/pid/show_topology.pid

と怒られました。
標準のパス以外の TREMA_TMP を指定すると動かないように見えます。

環境は以下です。

$ gem list | grep trema
trema (0.3.3)
$ git show | head -1

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

Labels

No labels
No labels

Type

No type

Projects

No projects

    Milestone

    No milestone

    Relationships

    None yet

    Development

    No branches or pull requests

    Issue actions